Instalação e renovação SSL (Resolvido)

Tudo BLZ? Sei que tem muitos alunos enfrentando dificuldades na insatalação do SSL como mostro nos cursos.
Isso se deve a uma atualização do acme.sh que adotou o ZeroSSL como padrão na instalação.
Neste vídeo abaixo explico a causa do problema e como resolver.

https://youtu.be/8GUKU_9VrCI

Comandos instruções utilizadas na aula:

Edite o arquivo de configuração do LetsEncrypt:

nano /etc/letsencrypt/config/account.conf

Insira a linha:
DEFAULT_CA=https://acme-v02.api.letsencrypt.org/directory

Insira seu token e e-mail do cloudFlare com os parâmetros abaixo:

SAVED_CF_Key='sua-key-aqui'
SAVED_CF_Email='seu-email-do-clloud-flare-aqui'

Depois salve o arquivo e reinicie os serviços com:
wo stack restart

Agora já deve conseguir emitir nos certificados com:

wo site update dominio.com --le --dns=dns_cf

Ou:

sudo -E wo site update dominio.com --le --dns=dns_cf

1 curtida

Boa tarde Gabriel,

Fiz aqui e deu certo. Obrigado!

Uma dúvida é… a renovação do SSL permanece automática após os 90 dias?

Sim.
Ele deve renovar normalmente.

Parabéns, funcionou perfeitamente.

Olá Gabriel
Estou tentando fazer a integração com o Route 53 da Amazon mas não encontro uma explicação em lugar algum…

eu tento colocar as credencias que me foram passadas através dos comados:

export  AWS_ACCESS_KEY_ID=XXXXXXXXXX
export  AWS_SECRET_ACCESS_KEY=XXXXXXXXXXXXXXX

Porem elas não aparecem no arquivo do account.conf. Gostaria de saber se eu posso colocar a variável lá e se sim, qual o nome da variável eu devo colocar? pois imagino que o SAVED_CF_ seja para o cloudflare.

Mesma duvida para o comando de instalação do SSL:
wo site update dominio.tld --le --dns=dns_cf
Qual o parâmetro que devo usar no lugar do “dsn_cf”?

Até onde sei o WordOps ainda não tem integração com Route 53. Sendo assim essa integração não vai funcionar.

Se trata de um site novo, migração ou renovação de ssl?

É um site novo que estamos tentando colocar o certificado e os DNS estão no Route 53 e não podemos tirar eles de lá…

Estranho que na documentação mesmo fala que tem integração com o Route 53:
https://docs.wordops.net/how-to/configure-letsencrypt-dns-api-validation/
Porem eu não encontro uma solução em lugar algum… Será que é um caso perdido mesmo?

Em site novo você deve conseguir ativar o SSL apontando o DNS e utilizando:
acme.sh --register-account -m seu-email@example.com --server zerossl

wo site update dominio.com --le

Tenta dessa forma.
É a forma mais simples.

Sabia da integração do WordOps com DNS CloudFlare e Digital Ocean.
Não sei se já chegaram a implementar a integração com Route 53. Se foi implementado ainda não tem documentação sobre.
Mas vou ver se consigo essa informação com o desenvolvimento.

O Route 53 é ótimo.

Olá Gabriel,

Como sugestão, indico vc inserir estes passos na descrição da aula “Instalação de SSL” do módulo 05 do curso superservidor, da forma detalhada como está aqui nesse post. Nesse momento, a descrição dessa aula não traz essas informações atualizadas.

Gastei umas 4 horas de tempo batendo cabeça para entender o erro na instalação do SSL até descobrir esse seu post na comunidade e respectivo vídeo que está no Youtube. Somente consegui instalar o SSL seguindo os passos deste seu post.

Abraço.

Essa aqui é uma solução temporária. Em pouco tempo tudo vai voltar a funcionar da exata forma como é mostrado nas aulas do curso.
Também temos muitas situações diferentes na instalação de SSL.
Exemplo: Instalação em subdominio, utilização de DNS que não é CloudFlare, SSL coringa e mais algumas variações.
E todas essas situações demandam de orientações.
A comunidade está aqui justamente para auxiliar em qualquer dificuldade, se qualquer conteúdo mostrado nos cursos não funcionar devidamente a comunidade é sempre o primeiro lugar para buscar.
Fico feliz que conseguiu resolver.

1 curtida

Pessoal, segui os passos acima e não funcionou para mim…Daí eu segui essa orientação e deu certo:

Quando você adiciona manualmente suas chaves no arquivo account.conf, ela deve ter a seguinte aparência:

CF_Key='xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
CF_Email='x@gmail.com'

diferente de como você tem atualmente:

SAVED_CF_Key='xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
SAVED_CF_Email='x@gmail.com'

Tente mudar e veja se isso faz diferença.

Nesse momento não deveria mais ter a necessidade de fazer essa configuração.
A ultima atualização do WordOps corrigiu isso. Basta seguir as exatas orientações da aula que tudo vai funcionar corretamente.

Pessoal,

Eu fiz esse procedimento numa instalação de Mautic e hoje me deparei com o site fora do ar por falha de certificado SSL. Eu não estou com a nuvem ativada no DNS no Cloudflare e o SSL estava como Completo (estrito).

Passei para Completo e voltou, mas depois cai novamente.

No site edit mostra que o certificado está expirado:

Nginx configuration mysql basic (enabled)
PHP Version 7.4

SSL enabled
SSL PROVIDER Lets Encrypt
SSL EXPIRY DATE -1

Não consegui renovar através de comando no SSH.

Alguma sugestão?

wo site update “site” --le=clean

wo site update “site” --le

Obrigado,

Pepe

Atualiza o WordOps com wo update --force
Depois tenta renovar com: acme.sh --renew-all

Se não conseguir renovar remove esse SSL com:
wo site update site.tld --le=clean

Depois reinstala com:
wo site update dominio.com --le --dns=dns_cf