RESOLVIDO: Comando ZIP não funcionando

Devido a um problema que enfrentei hoje estou migrando alguns sites para um novo servidor na digital Ocean seguindo o passo a passo do curso Super Servidor novo.

Como estou sem acesso ao Wordpress estou fazendo tudo via ssh, mas, depois de fazer o backup do Banco de dados, quando vou compactar tudo, conforme a aula, recebo o erro “zip: command not found”

Acredito que isso é devido ao meu server antigo não possuir o zip. Podem me ajudar como resolver?

Instalou o Zip no servidor? Se ainda não, rode o comando abaixo:

apt-get install zip unzip

Com isso ele vai instalar os pacotes para Compactar e Descompactar.

Espero ter ajudado.

Muito Obrigada Rafael! resolveu o problema!

1 curtida

Eu estou migrando de servidor porque o antigo ainda tá com o easy engine e tive o mesmo problema, na hora de fazer o backup do banco aparece o mesmo erro depois do comando zip -r …

Baixei o zip unzip, que aliás acho que já tinha no servidor e a mensagem continuou aparecendo.

zip unzip

Aí tentei usar esses dois comandos sugeridos: --fix-missing (deu command not found) e o apt-get update e aí deu apareceu essa mensagem:

Então tô aqui sem conseguir criar um backup e migrar meu site…

Mas você tem acesso ao Wordpress certo?
Se sim pode gerar o backup de outra maneira.
Pode usar o plugin Xcloner por exemplo.

Sim, tenho, são meus próprios sites. Você acha que seria melhor fazer a migração por plugin ou fazer a atualização do easy engine pra wordops? Se eu conseguisse resolver esse problema seria bem melhor, já que a migração por ssh é simples de fazer.

Neste caso faria a migração para outro servidor. Com certeza é melhor por diversas razões.
Migração tem diversas formas de fazer. Se está com dificuldades de fazer por SSH pode tranquilamente usar um plugin, ou mesmo mesclar as formas de migração.
Veja se essa aula ajuda: https://academy.gerenciandoweb.com.br/curso-super-servidor/migracao-com-duplicator/