Site WP esta aponta para outro dominio desconhecido

Olá Gabriel

Fiz a instalação pelo servidor Contabo e nele instalei sites WP e Mautic, ocorre que o site wp que instalei esta direcionando o dominio (negfazenda.com.br) do site para outro dominio (http://organicdrugmall.com/) isso significa que o site tenha sido invadido ???

Tentei acesso pelo wp-admin do site e não consigo pois ele direciona para esse dominio http://organicdrugmall.com/

Como posso resolver isso ?? Tem alguma solução ???

Realmente os 2 site Wordpress estão infectados!

Eu tenho o back dos sites o que devo fazer ? Deletar os sites e fazer novamente as instalações do wordpress no mesmo servidor e usar o back para migrar os sites ?

Ou o servidor esta infectado e tenho que obrigatoriamente usar um novo servidor ???
Nesse servidor infectado acabei de instalar o Mautic e pelo que percebi não esta infectado , o problema foi diretamente aos Sites Wordpress !
Minha duvida é se apagar os sites wordpress e instalar do zero resolve o problema ???

Pessoalmente contrataria um novo server. É mais seguro e a prova de falhas.
Segue as recomendações desta aula: https://academy.gerenciandoweb.com.br/seguranca-wordpress/limpando-sites-infectados/

Oi Gabriel !

Fiz a reinstalação do servidor como sugerido pelo suporte da Contabo o qual me informou que apagaria tudo o que estava no servidor !

No servidor invadido eu tinha 2 WP e 1 Mautic , no caso do servidor eu confiqgurei o DNS com um sub domínio vps.meudominio.com.br … assim como a instalação do mautic que também criei um sub domínio ads.meudominio.com.br o mesmo ambos com o mesmo dominio que uso para o meu site que aponta para uma outra plataforma de site que não é WP
Em resumo depois que criei esses 2 sub dominios o volume de visitas cresceu muito , acredito que deve ser por conta da invasão do servidor , mas eu só tinha apontando para esse servidor os sub dominios VPS.emudominio (servidor) / ads.meudominio (mautic) mesmo apagando tudo e reinstalando um novo servidor ainda aparece um volume de visita que eu sei que não vem do meu site , mesmo tendo todos as configurações do DNS de segurança como ensina na aula , acho que tem algo errado !

isso pode ser reflexo da invasão ???
Não sei o que pensar sobre isso pode me dar uma luz
Ainda não fiz a instalação do novo mautic e nem os outros sites WP sem ter a certeza que tudo esta correto

Esses relatórios do Cloudflare não dizem muito.
Veja os logs de acesso do servidor.
Sobre segurança o que temos de mais atualizado é o Módulo 06 e 07 do Curso Super Servidor