Servidor caindo, tem que dar Reboot

Gabriel, um servidor novo que estou migrando da Vultr para a DO e de EE na AgiusCloud para o WO, cai frequentemente do nada. Dá erro 521 http://prntscr.com/tfluql
Já deu uma mensagem como essa quando fui instalar o SSL: http://prntscr.com/tfltfp mas não tem relação, ás vezes fazendo migração dentro do painel do WP ele congela e o server cai.
Só volta quando dou reboot, já fiz isto várias vezes.
Não sei se me fiz entender.

1 curtida

Já investigou a causa da queda?
Como está o uso de recursos do servidor?

Acabou de acontecer de novo ao tentar instalar um novo site neste servidor. Deu algum erro de configuração de nginx e o server caiu. http://prntscr.com/tfvd4b http://prntscr.com/tfvebr

Como resolver este erro?

Provavelmente você tem algum erro na configuração do Nginx.
Usa o nginx -t para ver o registro do erro.

Isto a nível de servidor geral ou de dominio? Rodei no servidor e deu isto http://prntscr.com/tfx8zf

Como leio o arquivo log do WO, com o nano?

As configurações do Nginx parecem OK.
O comando para ativação do SSL que executou está errado.
Veja com atenção como está executando, falta o parâmetro --le, acredito que esse é o problema.

Funcionou a instalação do SSL, faltava um comando mesmo. Mas o próximo passo, Update Ngxblocker falhou e verifiquei a linha de comando.
http://prntscr.com/tfy3xq

E o servidor caiu de novo

Ao tentar instalar outro site, deu erro no mysql http://prntscr.com/tgcz1z
e o server caiu de novo mas agora erro 525 http://prntscr.com/tgd1kp

Olhando os gráficos de consumo da DO, notei que durante estas instalações acontecem picos de consumo de CPU e é quando o server cai.

Normal ter consumo maior durante instalações.

Mas sinceramente não entendi por que está administrando o servidor por linha de comando.
Afinal, segundo seu post está usando a Agius, sendo assim o ideal seria administrar o servidor pela Agius.
Acredito que os problemas que está enfrentando tem relação com isso.
A Agius, apesar de usar EasyEngine no servidor como base das configurações implementa muitos pacotes a mais e modifica muitos pacotes.
Administrando da maneira que está fazendo possivelmente vai gerar conflitos nas configurações e gerar alguns erros.

Tenta administrar seu servidor somente pelo painel da Agius.

eu estou migrando da Agius direto para a DO porque quero usar o WO, fiz de outros sites mas um deles travou e não consegui instalar. Aí agora criei outro server na DO para não deixar todos os sites no mesmo server, mas quando fui migrar por SSH não consegui fazer o backup do banco de dados, deu este erro: http://prntscr.com/th70ow
Refiz as permissões que você falou nas aulas mas não funcionou.

Quando fui migrar da Agius não consegui fazer via SSH por causa de algumas permissões ou outros erros que apareceram, aí fiz tudo via plugin de WP mesmo.

Esse erro do print pode representar que o user, senha ou nome do banco não estão corretos ou que o banco de dados não esta respondendo.
O site você está conseguindo acessar?

Criei um novo server e estou migrando os sites um por um para entender pq o primeiro estava lento e com erros, sendo que não teve invasão nem nada. Só que ao instalar o ngxblocker, deu algum erro na instalação no site, não no do servidor: http://prntscr.com/tjn90x
A mensagem está bem diferente da instalação que você fez na aula. Pior que no outro server tinha acontecido isto e nem me liguei.

Já teve outro relato sobre.
Apesar da tela exibida ele está sendo instalado corretamente.