Instalação Admin Tools

Não estou conseguindo acessar o Admin Tools do meu WordOps eu fiz a instalação através do comando wo stack install --admin e também fiz a liberação de firewall p/ a porta 22222 mas ao tentar acessar o painel via https://numero_de_ip/22222 não consigo acessar.

O correto seria https://numero_de_ip:22222

Sim desculpe escrevi errado estou usando “dois pontos” hehe mesmo assim nada, eu estou acreditando que desativei a porta 22222 no firewal mas não me lembro como voltar lá pra adiciona-las novamente

Qual firewall está usando.
CSF ou UFW?

UFW Gabriel mas posso instalar o CSF

Pode manter o UFW.
Para liberar a porta 22222 usa:

sudo ufw allow 22222

Estou com o mesmo problema aqui.
Criei a regra no Firewall do Google Cloud e tbm usei o sudo ufw allow 22222 via SSH e mesmo assim não abre as Ferramentas Administrativas.

Está com CloudFlare ativo?

só o record A e CNAME

Certo.
O CloudFlare bloqueai qualquer acesso por portas paralelas.
Desabilitando deve funcionar.

Se funcionar você pode criar um recor A e direciona-lo para o servidor somente com o objetivo de fazer os acessos as ferramentas administrativas.

Opa Grabriel hojé é feriado aqui em Joinville, aniversário da cidade e aproveitei para fazer uma imersão rever aulas, etc… estou tendo um problema ao instalar o admin do wordops ele me retorna a seguinte mensagem:


Estive vendo os logs e tem algo assim:
apt --fix-broken install’ with no packages (or specify a solution). a sorte que eu havia feito o snapshot na CONTABO, pois esse comando ferrou com parte do banco de dados de alguns sites:
executei no terminal: apt --fiz-broken install (quando a ficha caiu eu vi que se tratava de banco de dados,
Poderia me ajudar a resolver isso eu gostaria de instalar o painel admin, uma vez que tenho 4 nucleos de CPU e 8gb de ram.

Agradeço a atenção.

Como tem um snapshot força a atualização do WordOps com wo update --force
Depois tenta novamente.

Ok estou fazendo agora ja te dou retorno

1 curtida

eu atualizei agora esta assim: não acieta os comandos:
image f

Executa os comandos:

sudo pip install -U pip setuptools

sudo python3 -m pip install -I wordops

executei os dois comandos, mas continua o erro,

tentei dar um restart o erro continua.

Neste log:

tail /var/log/wo/wordops.log

tem alguma informação?

^[[31m2021-03-09 17:09:22,735 (ERROR) wo : ^[[91mCheck the WordOps log for more details tail /var/log/wo/wordops.log and please try again…^[[0m
^[[32m2021-03-09 20:36:48,979 (INFO) wo : Initializing WordOps Database^[[0m
^[[32m2021-03-09 20:36:48,991 (INFO) wo : ^[[94mDownloading update script ^[[0m
^[[32m2021-03-09 20:36:49,280 (INFO) wo : ^[[94m[^[[0mDone^[[94m]^[[0m
^[[32m2021-03-09 20:36:49,281 (INFO) wo : ^[[94mupdating WordOps, please wait…^[[0m
^[[32m2021-03-09 20:47:41,606 (INFO) wo : Initializing WordOps Database^[[0m
^[[36m2021-03-09 20:47:41,615 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for phpMyAdmin ^[[0m
^[[36m2021-03-09 20:47:41,616 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for phpRedisAdmin^[[0m
^[[36m2021-03-09 20:47:41,617 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Composer ^[[0m
^[[36m2021-03-09 20:47:41,618 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Adminer ^[[0m
^[[36m2021-03-09 20:47:41,618 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Netdata^[[0m
^[[36m2021-03-09 20:47:41,618 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for WO-Dashboard^[[0m
^[[36m2021-03-09 20:47:41,618 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for eXtplorer^[[0m
^[[36m2021-03-09 20:47:41,619 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for cheat.sh^[[0m
^[[36m2021-03-09 20:47:41,619 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for nanorc^[[0m
^[[36m2021-03-09 20:47:41,619 (DEBUG) wo.core.logging : ^[[95mRunning command: mysqladmin ping^[[0m
^[[36m2021-03-09 20:47:41,652 (DEBUG) wo.core.logging : ^[[95mCommand Output: mysqld is alive
,
Command Error: ^[[0m
^[[36m2021-03-09 20:47:44,444 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for utils^[[0m
^[[36m2021-03-09 20:47:44,447 (DEBUG) wo.core.logging : ^[[95mCalling pre_pref^[[0m
^[[32m2021-03-09 20:47:44,447 (INFO) wo : ^[[94mUpdating apt-cache ^[[0m
^[[32m2021-03-09 20:47:49,567 (INFO) wo : ^[[92mUpdating apt-cache ^[[0m
^[[32m2021-03-09 20:47:49,568 (INFO) wo : ^[[94mInstalling APT packages ^[[0m
Reading package lists…
Building dependency tree…
Reading state information…
nano is already the newest version (4.8-1ubuntu1).
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.3 (>= 1:10.3.25-0ubuntu0.20.04.1) but 1:10.3.24+maria~focal is to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
^[[32m2021-03-09 20:47:50,323 (INFO) wo : ^[[94m^[[91mOops Something went wrong!!^[[0m
^[[31m2021-03-09 20:47:50,324 (ERROR) wo : ^[[91mCheck the WordOps log for more details tail /var/log/wo/wordops.log and please try again…^[[0m
^[[32m2021-03-09 20:48:57,643 (INFO) wo : Initializing WordOps Database^[[0m
^[[32m2021-03-09 20:48:57,652 (INFO) wo : ^[[94mPHP7.2-FPM is not installed^[[0m
^[[32m2021-03-09 20:48:57,654 (INFO) wo : ^[[94mPHP7.4-FPM is not installed^[[0m
^[[32m2021-03-09 20:48:57,658 (INFO) wo : ^[[94mNetdata is not installed^[[0m
^[[36m2021-03-09 20:48:57,659 (DEBUG) wo.core.logging : ^[[95mRestarting service: nginx^[[0m
^[[32m2021-03-09 20:48:57,659 (INFO) wo : ^[[94mTesting Nginx configuration ^[[0m
^[[32m2021-03-09 20:48:58,408 (INFO) wo : ^[[92mTesting Nginx configuration ^[[0m
^[[32m2021-03-09 20:48:58,408 (INFO) wo : ^[[94mRestarting Nginx^[[0m

^G Get Help ^O Write Out ^W Where Is ^K Cut Text ^J Justify ^C Cur Pos M-U Undo M-A Mark Text M-] To Bracket M-Q Previous
^X Exit ^R Read File ^\ Replace ^U Paste Text ^T To Spell ^_ Go To Line M-E Redo M-6 Copy Text ^Q Where Was M-W Next

ACHO QUE AS DO ERROS SÃO ESSAS

^[[32m2021-03-09 20:49:00,719 (INFO) wo : ^[[92mRestarting php7.3-fpm^[[0m
^[[36m2021-03-09 20:49:00,720 (DEBUG) wo.core.logging : ^[[95mRestarting service: mysql^[[0m
^[[32m2021-03-09 20:49:00,720 (INFO) wo : ^[[94mRestarting mysql ^[[0m
^[[32m2021-03-09 20:49:05,017 (INFO) wo : ^[[92mRestarting mysql ^[[0m
^[[32m2021-03-09 20:49:15,962 (INFO) wo : Initializing WordOps Database^[[0m
^[[36m2021-03-09 20:49:15,967 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for phpMyAdmin ^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for phpRedisAdmin^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Composer ^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Adminer ^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for Netdata^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for WO-Dashboard^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for eXtplorer^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for cheat.sh^[[0m
^[[36m2021-03-09 20:49:15,968 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for nanorc^[[0m
^[[36m2021-03-09 20:49:15,969 (DEBUG) wo.core.logging : ^[[95mRunning command: mysqladmin ping^[[0m
^[[36m2021-03-09 20:49:15,983 (DEBUG) wo.core.logging : ^[[95mCommand Output: mysqld is alive
,
Command Error: ^[[0m
^[[36m2021-03-09 20:49:18,440 (DEBUG) wo.core.logging : ^[[95mSetting packages variable for utils^[[0m
^[[36m2021-03-09 20:49:18,440 (DEBUG) wo.core.logging : ^[[95mCalling pre_pref^[[0m
^[[32m2021-03-09 20:49:18,441 (INFO) wo : ^[[94mUpdating apt-cache ^[[0m
^[[32m2021-03-09 20:49:21,865 (INFO) wo : ^[[92mUpdating apt-cache ^[[0m
^[[32m2021-03-09 20:49:21,866 (INFO) wo : ^[[94mInstalling APT packages ^[[0m
Reading package lists…
Building dependency tree…
Reading state information…
nano is already the newest version (4.8-1ubuntu1).
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.3 (>= 1:10.3.25-0ubuntu0.20.04.1) but 1:10.3.24+maria~focal is to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
^[[32m2021-03-09 20:49:22,653 (INFO) wo : ^[[94m^[[91mOops Something went wrong!!^[[0m
^[[31m2021-03-09 20:49:22,654 (ERROR) wo : ^[[91mCheck the WordOps log for more details tail /var/log/wo/wordops.log and please try again…^[[0m