Erro no mariadb

Bom dia, após tentar atualizar um plugin notei que o site estava lento e caindo, vui ver os logs e deu isso:

root@membros:~# systemctl status mariadb.service

  • mariadb.service - MariaDB 10.3.26 database server
    Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset:
    Drop-In: /etc/systemd/system/mariadb.service.d
    `-limits.conf, migrated-from-my.cnf-settings.conf
    Active: failed (Result: exit-code) since Thu 2020-11-12 07:48:44 -03; 18s ago
    Docs: man:mysqld(8)
    https://mariadb.com/kb/en/library/systemd/
    Process: 5264 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WS
    Process: 5113 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR
    Process: 5104 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START
    Process: 5100 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/ru
    Main PID: 5264 (code=exited, status=1/FAILURE)
    Status: “MariaDB server is down”

Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [Note] InnoDB: Start
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Plugin 'Inno
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Plugin 'Inno
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [Note] Plugin 'FEEDB
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Unknown/unsu
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Aborting
Nov 12 07:48:44 membros systemd[1]: mariadb.service: Main process exited, code=e
Nov 12 07:48:44 membros systemd[1]: Failed to start MariaDB 10.3.26 database ser
Nov 12 07:48:44 membros systemd[1]: mariadb.service: Unit entered failed state.
lines 1-23…skipping…

  • mariadb.service - MariaDB 10.3.26 database server
    Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/mariadb.service.d
    -limits.conf, migrated-from-my.cnf-settings.conf Active: failed (Result: exit-code) since Thu 2020-11-12 07:48:44 -03; 18s ago Docs: man:mysqld(8) https://mariadb.com/kb/en/library/systemd/ Process: 5264 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE) Process: 5113 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=cd /usr/bin/…; /usr/bin/galera_recovery`; [ $? -
    Process: 5104 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 5100 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
    Main PID: 5264 (code=exited, status=1/FAILURE)
    Status: “MariaDB server is down”

Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [Note] InnoDB: Starting shutdown…
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Plugin ‘InnoDB’ init function returned error.
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [Note] Plugin ‘FEEDBACK’ is disabled.
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Unknown/unsupported storage engine: InnoDB
Nov 12 07:48:44 membros mysqld[5264]: 2020-11-12 7:48:44 0 [ERROR] Aborting
Nov 12 07:48:44 membros systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
Nov 12 07:48:44 membros systemd[1]: Failed to start MariaDB 10.3.26 database server.
Nov 12 07:48:44 membros systemd[1]: mariadb.service: Unit entered failed state.
Nov 12 07:48:44 membros systemd[1]: mariadb.service: Failed with result ‘exit-code’.

Como resolver?

Já verificou o armazenamento do servidor?
Pode usar df -h para verificar.

Bom dia gabriel obrigado pela resposta, então, encontrei o seguinte:

root@membros:~# df -h
Filesystem Size Used Avail Use% Mounted on
udev 2.0G 0 2.0G 0% /dev
tmpfs 396M 7.2M 389M 2% /run
/dev/vda1 25G 25G 0 100% /
tmpfs 2.0G 0 2.0G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 2.0G 0 2.0G 0% /sys/fs/cgroup
tmpfs 396M 0 396M 0% /run/user/0

ser que o problema é esses 100% ai?

eu vi aqui tb:

-rw-rw---- 1 mysql mysql 128790528 Nov 12 08:20 ib_logfile1
-rw-rw---- 1 mysql mysql 38797312 May 25 14:46 ib_logfile1.bak
-rw-rw---- 1 mysql mysql 155189248 Nov 12 08:20 ib_logfile101

olha o tamanho desses logs

Sim, o erro é por causa de armazenamento cheio.
Pode verificar o tamanho de arquivos com
du -hs *

Mas antes de apagar faz um snapshot do servidor.

O problema esta dentro da pasta mysql la dentro na pasta do meu banco de dados achei algo com 18 gigas que nao tem nome.

Acontece.
Geralmente são logs.
Me fala mais sobre a configuração que usa atualmente no servidor.
Acontecia muito com o EasyEngine. Com WordOps ainda não vi acontece.

Analisando aqui foi o banco de dados do meu site. No dia 08/11 à meia noite começou uma enxurrada de arquivos no diretório. Eu tenho um backup do dia 02/11 se nada der certo vou restaurar. Provavelmente um plugin. Uso um servidor Debian com Wordops 4 cpu 2 mega 50 gb

Certo.
Faz um snapshot, apaga esses arquivos com exceção do arquivo index.
Depois pode ser necessário editar o arquivo index e apagar todas as linhas que fazem referencia aos arquivos que apagou.

1 curtida

Esse arquivo fica dentro da pasta /var/lib/mysql/bancodedados?
Não estou encontrando. Apaguei alguns arquivos para testar e deu error establishing a database connection. Restaurei o snapshot.

Descobrimos o problema, era um plugin chamado Wp reset, ele faz snapshots automaticos toda vez que um plugin é atualizado ou instalado, lotou o servidor. Já resolvido.
Desde já agradeço sua ajuda Gabriel.

Opa.
Que bom que resolveu.
Muito obrigado pelo feddback.